Friday, March 13, 2009

I plugged in a version of Apache Xalan that I downloaded from the

Question :I plugged in a version of Apache Xalan that I downloaded from the
Apache Web site, and now I get errors when I try to transform documents.
What is the problem? (EJB)

Answer :You must ensure that the version of Apache Xalan you download from the
Apache Web site is compatible with Apache Xerces version 1.3.1. Because
you cannot plug in a different version of Apache Xerces (see the preceding
question), the only version of Apache Xerces that is compatible with
WebLogic Server 6.1 is 1.3.1.
The built-in parser (based on version 1.3.1 of Apache Xerces) and
transformer (based on version 2.0.1 of Apache Xalan) have been modified
by BEA to be compatible with each other.

No comments: